Problem installing ds packages

!pip install qeds pyLDAvis gensim folium xgboost descartes pyarrow graphviz --upgrade

I got the error message:

File “”, line 268, in _run_cmake
raise RuntimeError(‘Not supported on 32-bit Windows’)
RuntimeError: Not supported on 32-bit Windows

ERROR: Failed building wheel for pyarrow
ERROR: Could not build wheels for pyarrow which use PEP 517 and cannot be installed directly

ANything regarding Jupyterlab extension fails

An error occured.
ValueError: Please install nodejs >=10.0.0 before continuing. nodejs may be installed using conda or directly from the nodejs website.
See the log file for details: C:\Users\Armmer\AppData\Local\Temp\jupyterlab-debug-wtqgsrnp.log

Could you please kindly give me suggestion?


Hi @Arm_Nakornthab

Could you try installing the packages one at a time to figure out which one is creating trouble?

It looks like it is coming from pyarrow (or maybe qeds if pyarrow is a dependency of qeds) and that it can’t run on your machine because you have a 32-bit Windows system. Is the error message correct that you are on a 32-bit machine?

1 Like

Hi @cc7768 ,

Here is a list of installed packages, respectively from

geopandas 0.6.1 py_0
python-graphviz 0.14.1 pypi_0 pypi
nodejs 10.13.0
pyldavis 2.1.2 pypi_0 pypi
gensim 3.8.3 pypi_0 pypi
folium 0.11.0 pypi_0 pypi
descartes 1.1.0 pypi_0 pypi
graphviz 2.38 hfa6e2cd_3

nodejs had a problem installing from the command given on the quantecon ds website. I need to use

“conda install -c anaconda nodejs” instead.

There are 3 packages having problem which are qeds, xgboost, and pyarrow. All of which seems to originate from 32-bit platform, which is my computer (It’s very old.)

Jupyterlab extension has one problem with this command:

“jupyter labextension install jupyterlab-plotly@1.5.2 --no-build”

An error occured.
"jupyterlab-plotly@1.5.2" is not compatible with the current JupyterLab
Conflicting Dependencies:
JupyterLab Extension Package
>=2.1.0 <2.2.0 >=1.3.0 <2.0.0 @jupyterlab/rendermime-interfaces
See the log file for details: C:\Users\Armmer\AppData\Local\Temp\jupyterlab-debug-ig8jndao.log

This also leads to Jupyter lab build fails

Build failed.
[LabBuildApp] JupyterLab 2.1.5
[LabBuildApp] Building in C:\ProgramData\Anaconda3\share\jupyter\lab
[LabBuildApp] Building jupyterlab assets (build:prod:minimize)

Troubleshooting: If the build failed due to an out-of-memory error, you
may be able to fix it by disabling the dev_build and/or minimize options.

If you are building via the jupyter lab build command, you can disable
these options like so:

jupyter lab build --dev-build=False --minimize=False

You can also disable these options for all JupyterLab builds by adding these
lines to a Jupyter config file named

c.LabBuildApp.minimize = False
c.LabBuildApp.dev_build = False

If you don’t already have a file, you can create one by
adding a blank file of that name to any of the Jupyter config directories.
The config directories can be listed by running:

jupyter --paths


  • dev-build: This option controls whether a dev or a more streamlined
    production build is used. This option will default to False (ie the
    production build) for most users. However, if you have any labextensions
    installed from local files, this option will instead default to True.
    Explicitly setting dev-build to False will ensure that the production
    build is used in all circumstances.

  • minimize: This option controls whether your JS bundle is minified
    during the Webpack build, which helps to improve JupyterLab’s overall
    performance. However, the minifier plugin used by Webpack is very memory
    intensive, so turning it off may help the build finish successfully in
    low-memory environments.

An error occured.
RuntimeError: JupyterLab failed to build
See the log file for details: C:\Users\Armmer\AppData\Local\Temp\jupyterlab-debug-aezfakgf.log

This looks messy so let me sum up.
1. My 32-bit system cannot install qeds, xgboost pyarrow and the jupyter lab build failed.
2. My 64-bit yet Windows 7 can install every component except nodejs I need to install version 10.13.0. (nodejs 14.5.0 was successfully installed but it showed error when I tried jupyterlab extension) **
**** I am not sure whether this leads to the error when I tried jupyter labextension install jupyterlab-plotly@1.5.2 --no-build. However, there is no error message showing build failed in this case, so the only things unsuccessful was install jupyterlab-plotly@1.5.2.

My questions are:

  1. Does this mean I cannot use this (32-bit) computer to study the DataScience section?
  2. Can I use the cloud setup instead using this computer ? (I found the execution is a bit stangely slow, e.g. simple arithmetics took 2 seconds or more.)
  3. Can I do my own project that has to use those relevant packages using cloud setup via ?

I did try to install these on 64-bit system, but my Windows is 7 and it showed error messages like nodejs is for Windows 8.1 or later, and my 64-bit system cannot run any jupyterlabextension.

Thanks very much.!

Maybe a version bump is required on the jupyterlab extensions now that jupyterlab 2 is out?

1 Like

Hi @jlperla ,

That is strange. The version of Jupyterlab on is 2.1.1. I have not yet gone far into ds section, so I am not sure whether it works appropriately.

Windows 7 hit its end-of-life earlier this year (ie Microsoft gives only 10 year support promises, so trying to get anything up and running on it is a lost cause). But if you have an extremely old computer as well, I doubt that the upgrade to windows 10 would solve your problems… Software these days is far more memory and CPU intensive.

If you can’t upgrade and get a newer machine/OS then I suggest colab. It will be very responsive.

1 Like

Short answer: nodejs 14.5.0 should work on a 64-bit Win 10 machine, and currently you can remove all the version limits of the Jupyterlab extensions. For example, just run jupyter labextension install jupyterlab-plotly --no-build