Error installing quantecon packages

I’m having issues installing the required quantecon packages. When I run the command

using InstantiateFromURL
github_project("QuantEcon/quantecon-notebooks-julia", version = "0.4.0")

I get the following error

I then tried to run Julia as an administrator but then simply nothing happens. Please help me I need to use Julia to teach dynamic programming as TA.

That looks like a fake warning. For whatever reason, on windows it has that some packages show the symlinks warnings even though it is irrelevant

It should also only show only be obnoxious the first time.

Do any thing else break after that seta up the environments? That line doesn’t do much if the necessary packages are installed and setup.

Also, are you following the instructions to clone all of the notebooks from github rather than downloading directly? It will make your life a lot easier. Ie see

I also tried with GitHub desktop and the notebook installation step fails: it says "You do not have permission to push quantecon-notebooks-julia. I had to install Github by using “Run as administrator” on Windows, otherwise the initial installation also failed. I think the problem might e connected with administrator priviledges but I do not know how to get around it. I aso tried with a different windows PC and encountered the same problem.

That isn’t an error. What that usually means is you must have had local changes to the files and were trying to push them to the server. Git is two-directional, so after cloning you should only go to the github desktop if you want to reset the notebooks. You would never want “Push” to that server.

That image you showed me looks like everything worked great! Did the next steps of running jupyter lab

OK, but that doesn’t sound like it has anything to do with any of the QE stuff… just how you setup your windows. Or am I missing something?

The next steps of running jupyter lab do not work. I am unable to plot anything even after installing the required package using the Instantiate command

It looks like you may have started jupyterlab in a slightly different order than the instructions).

In a new cell on that notebook, type and execute (making sure it is on its own)
] instantiate

But that has to happen after the github_project executes, so the package is activated. Running the instantiation will take 15 minutes or more