Add QuantEcon.py Libarary


#1

Hi all,

I am a very beginner in Python.

I am trying to install the QuantEcon.py library by typing on the notebook: QuantEcon.py !pip install quantecon.
However, it showed the error as follows.

"!pip install quantecon

!pip install quantecon

Requirement already satisfied: quantecon in c:\users\hienh\anaconda3\lib\site-packages (0.4.2) Requirement already satisfied: requests in c:\users\hienh\anaconda3\lib\site-packages (from quantecon) (2.19.1) Requirement already satisfied: scipy>=1.0.0 in c:\users\hienh\anaconda3\lib\site-packages (from quantecon) (1.1.0) Requirement already satisfied: sympy in c:\users\hienh\anaconda3\lib\site-packages (from quantecon) (1.1.1) Requirement already satisfied: numpy in c:\users\hienh\anaconda3\lib\site-packages (from quantecon) (1.15.1) Requirement already satisfied: numba>=0.38 in c:\users\hienh\anaconda3\lib\site-packages (from quantecon) (0.39.0) Requirement already satisfied: idna<2.8,>=2.5 in c:\users\hienh\anaconda3\lib\site-packages (from requests->quantecon) (2.7) Requirement already satisfied: certifi>=2017.4.17 in c:\users\hienh\anaconda3\lib\site-packages (from requests->quantecon) (2018.8.24) Requirement already satisfied: chardet<3.1.0,>=3.0.2 in c:\users\hienh\anaconda3\lib\site-packages (from requests->quantecon) (3.0.4) Requirement already satisfied: urllib3<1.24,>=1.21.1 in c:\users\hienh\anaconda3\lib\site-packages (from requests->quantecon) (1.23) Requirement already satisfied: llvmlite>=0.24.0dev0 in c:\users\hienh\anaconda3\lib\site-packages (from numba>=0.38->quantecon) (0.24.0)

twisted 18.7.0 requires PyHamcrest>=1.9.0, which is not installed. You are using pip version 10.0.1, however version 18.1 is available. You should consider upgrading via the ‘python -m pip install --upgrade pip’ command."

I then tried to type ‘python -m pip install --upgrade pip’ in the notebook and run, but there is an error again:
File “”, line 1
python -m pip install --upgrade pi
^
SyntaxError: invalid syntax

So, I don’t know how to fix it?
Could anyone kindly give me some suggestions?

Thank you!


#2

Hi, the installation worked actually. It’s jjst suggesting that you upgrade the python package manager pip. If you type !pip install —upgrade pip It should work


#3

Thanks a lot for your help!