Errors in Julia QuantEcon lectures

There are some problems with data frames in the lecture:

Thanks for the report. Somehow missed coverage on that one. @arnavs can you fix it and push a change?

Thanks @kirtsar, good catch. Will push a fix tomorrow.

Thanks @kirtsar for the report. This was a matter of making sure all the proper dependencies etc. was installed on the machine we use to build the HTML.

It’s pushed up now. Note that this was an HTML-only problem, so the quantecon-notebooks-julia is still good to go.

Edit: Note, the javascript messages are still ugly, but all the Julia output displays and works.

I am using Julia 1.4.0, and I find that github_project(“QuantEcon/quantecon-notebooks-julia”, version = “0.5.0”, instantiate = true) results in some GitError. I list them as below:

ERROR: failed to clone from, error: GitError(Code:ERROR, Class:OS, failed to read data: The server returned an invalid or unrecognized response

GitError(Code:ERROR, Class:OS, failed to read data: The server returned an invalid or unrecognized response)

Hmm… Smells like some kind of blip in git downloads. @arnavs can you do a quick check to see if there are any Julia 1.4 errors like this?

Thanks for the report!

@zhiyuanryanchen I tried this to set up my 1.4 system, and didn’t see this.

A few things:

  1. Are you using the official 1.4 binaries? See this issue involving this libgit issue which you may be running into if not.

There’s also this discussion, which could be a good reference.

  1. Can you confirm that you can access GitHub normally (i.e., through the browser?) I don’t think that is the issue, but worth checking.

  2. You might run into some precompilation issues if you work past the issue, e.g. with When we update everything to Julia 1.4, that will be removed.

Also, I have never, ever regretted deleting my .julia folder for my user and starting fresh.

Then try to run that instantiate line again

Thank you! I am using the official 1.4 binaries. For other things, I need to check. The problem is that it takes a lot of time to compile. Probably it’s because of a bad internet connections.

@zhiyuanryanchen If the goal is to run the QE lectures, I’d say just stick with 1.3 at this point. I don’t think 1.4 will be a good experience (given precompilation difficulties) anyways.

But let us know what ends up doing the trick, if you find it.

(And Jesse’s comment about deleting things and starting fresh is always good advice for Julia.)

Yeah, that could be a killer with setting up Julia. One option is to comment out the github_project( lines in the jupyter notebooks and only install packages as you need them and it says a package isn’t 8nstaoled. Not all packages are required for all lectures.

That said, the downside is that it is easy to get into a place where some package version is incompatible with another one, or that the latest version of a package has a bug that breaks something in some lecture… So there is only so much we can do to help if it doesn’t work

I have tried what you have suggested, still not working. I will try Julia 1.3. Thank you!